Active Directory domain join fails for new hammer3 manage iq appliance

#1

Hi, I am trying to add my manage iq appliances to active directory. Getting below error.
It says usercreds error. in reality t’s not the creds error. The account is very powerful account and we use the same for adding thousands of machines to AD. Also we have all required packages.
i enabled NM and tried realm join. Can some one help me with this?
I just deployed a simple fine3 appliance and able to add to domain. But it fails for g4 and hammer all version. with same credentials. can some one help, whats that changed from fine3 to g4 and h3 interms of ad joining?

===[root@miqweb-h3-01d network-scripts]# tailf /var/log/messages
Mar 28 03:14:07 miqweb-h3-01d systemd: Started Realm and Domain Configuration.
Mar 28 03:14:07 miqweb-h3-01d realmd: * Resolving: _ldap._tcp.xxxxxx
Mar 28 03:14:07 miqweb-h3-01d realmd: * Performing LDAP DSE lookup on: IP
Mar 28 03:14:07 miqweb-h3-01d realmd: * Performing LDAP DSE lookup on: IP
Mar 28 03:14:07 miqweb-h3-01d realmd: * Successfully discovered: my_domain(domain name)
Mar 28 03:14:13 miqweb-h3-01d realmd: * Required files: /usr/sbin/oddjobd, /usr/libexec/oddjob/mkhomedir, /usr/sbin/sssd, /usr/bin/net
Mar 28 03:14:13 miqweb-h3-01d realmd: * LANG=C LOGNAME=root /usr/bin/net -s /var/cache/realmd/realmd-smb-conf.YLRVYZ -U domain_Admin ads join domain_name
Mar 28 03:14:13 miqweb-h3-01d realmd: Enter domain_Admin’s password:
Mar 28 03:14:13 miqweb-h3-01d realmd: Failed to join domain: failed to lookup DC info for domain ‘domain_name’ over rpc: The attempted logon is invalid. This is either due to a bad username or authentication information.
Mar 28 03:14:13 miqweb-h3-01d realmd: ! Joining the domain domain_name failed

#2

Have you tried to find and compare the relevant realmd config files?

Just in case, there is some official documentation on AD integration: