Add amazon cloud provider behind proxy?


#1

I am trying to add the Amazon Cloud provider but i am behind a proxy. Is there a way to configure proxy information in order to successfully add the provider?


#2

Yes, we have the ability to configure a proxy server for Amazon. It can be set through the Advanced Configuration Settings in the http_proxy section. I don’t think there’s a way to do it with the native UI at this time. @dclarizio @hkataria Can you verify? Unfortunately, if you have multiple servers configured you will have to set this setting on each server’s configuration.


#3

thanks, will give that a try.


#4

Hi Mark, where you config proxy setting for manageIQ direct at proxy setting on linux ?
Please Help!!


#5

Please see the emv.log:

[root@manageiq ~]# tail -f /var/www/miq/vmdb/log/evm.log |grep -i amazon
[----] I, [2015-07-29T16:33:14.081320 #8122:d69e94] INFO – : MIQ(EmsAmazon.wit h_provider_connection) Connecting through EmsAmazon: [Amazon SP]
[----] E, [2015-07-29T16:33:46.060553 #8122:d69e94] ERROR – : MIQ(EmsAmazon.ver ify_credentials) Error Class=Errno::EHOSTUNREACH, Message=No route to host - con nect(2)


#6

You might be running into this issue:

https://github.com/ManageIQ/manageiq/issues/2175