Add Azure Cloud Provider


#1

If I try to add Azure Provider to CloudForms and verify provided credentials then there is the error below in emv.log.

ERROR – : MIQ(ManageIQ::Providers::Azure::CloudManager#verify_credentials) Error Class=Errno::ECONNREFUSED, Message=Connection refused - connect(2) for “login.windows.net” port 443

The appliance is running behind a proxy. Do I need to specify the proxy settings somewhere for Azure? Amazon Provider works properly.

Thanks,
Karel


[Solved] GCE provider behind proxy
#2

@blomquisg @bronaghs @djberg96 Can you help out Karel?


#3

@Karel I’m afraid it’s not supported at the moment. We need to add support proxy support in our azure-armrest gem first. I’ve added an enhancement request: