Adding Kubernetes container provider in Capablanca


#1

I’m am trying to add a Container Provider in Capablanca beta, getting the following response when validating my token;

Credential validation was not successful: SSL_connect returned=1 errno=0 state=SSLv2/v3 read server hello A: unknown protocol

Port 8080 on the target machine is not SSL, it looks like a secure kube-apiserver is a requirement, correct? Are there any examples/how-to’s to add a Kubernetes container provider floating around?


#2

Hi @ozmark at the moment SSL is enforced for ManageIQ to connect to Kubernetes and OpenShift.

Also you may want to look at:

https://github.com/kubernetes/kubernetes/blob/master/docs/admin/authentication.md

for information on how to enable the token-based authentication.