Adding oVirt to ManageIQ


#1

I see in the providers option, there is RHEV but not oVirt. I’ve attempted to add oVirt however, no matter which credentials I use, it fails. We are using Active Directory to authenticate oVirt users however, I’ve tried those as well as the master admin account for oVirt. Can really find much documentation though on the proper steps to add oVirt…

Clarification: C & U Database - unsure which login information to use. Strangely, I can connect to oVirt to see the clusters, but not sure what to use for the C & U database credentials.


#2

Hi @BillBill

Can you tell me the version of the ManageIQ appliance that you’re running and the version of oVirt you’re using?

Also, can you check the evm.log file to see if there are any errors related to validating the credentials?

RE: RHEV but no oVIrt; yeah, that’s something we still mean to fix. We will eventually show oVirt in that list.

As far as I know, however, the RHEV provider selection should work with both RHEV and oVirt.

RE: the “C& U Database” credentials; we connect directly to the Data Warehouse database to collect metrics for RHEV and oVIrt. If you choose to collect metrics, you would need to enter the database username and password. And, on very recent versions of ManageIQ, the database for the Data Warehouse can be on a separate IP address than the oVirt manager REST endpoint. If you don’t see fields to fill in endpoints for the “C & U Database”, then you can either upgrade to the latest appliance (Darga version), or make sure that your Data Warehouse database is at the same IP address as the oVirt manager REST endpoint.

Collecting metrics will enable features related to reporting, right size recommendations, and various policies. And the “C & U Credentials” are optional. You should only enter credentials there if you want to collect metrics for oVirt.


#3

Hi @BillBill

Perhaps I’m stating the obvious, but for ‘username’ field you should enter ‘username@profile’, for instance ‘admin@internal’, and for the password field the matching one for that user.

Which ovirt version are you using ?


#4

For the future reference. In following screenshot, user name field should be like “admin@internal”.
This is on a fine-1 and oVirt 4.1.2