Amazon EC2 provider


#1

Hi,

I get an error “Credential validation was not successful: Unexpected response returned from system: execution expired” if I try to add new cloud provider Amazon EC2 via Access Key ID and Secret Access Key.

I use this version of Vmware virtual appliance manageiq-vsphere-capablanca-1.ova

These are these errors in evm.log file

ERROR – : MIQ(ManageIQ::Providers::Amazon::CloudManager#verify_credentials) Error Class=Net::OpenTimeout, Message=execution expired
WARN – : MIQ(ManageIQ::Providers::Amazon::CloudManager#authentication_check_no_validation) type: [“default”] for [] [AWS_SandBox] Validation failed: error, Unexpected response returned from system: execution expired
WARN – : MIQ(AuthUseridPassword#validation_failed) [ExtManagementSystem] [], previously valid on: , previous status: []
INFO – : MIQ(AuthUseridPassword#after_authentication_changed) [ExtManagementSystem] [], previously valid on: []
ERROR – : MIQ(ems_cloud_controller-create): Credential validation was not successful: Unexpected response returned from system: execution expired

Thanks for help,
Karel


#2

The issue was related to proxy. I set a proxy and it works now.


#3

How did u add the proxy? Is it through /etc/profile?
Is there any way to add the proxy in manageiq interface?


#4

I have set the proxy via the web interface. Configure -> Configuration -> Select manageiq instance on left side (under zone) -> advanced -> Configuration File to Edit “EVM Server Main Configuration”


#5

Hi Karel,

Thank you very much for the reply :slight_smile:

I added the http_proxy(https_proxy was not there). I guess it worked to eliminate the error, but getting a new error as below

“Credential validation was not successful: Unexpected response returned from system: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed”

Probably its due to the certificate issued by proxy server(not sure whether any certificate issued by proxy)…

Now I am trying to avoid connecting through 443 and instead using 80 to connect to aws.amazon.com(not sure whether its possible) Also I have seen some parameter like “web services: consume_protocol and provide_protocol” in the configuration and not sure whether its related to that. Do you have any suggestions?


#6

I did’t have such an issue but try to check log files - e.g /var/www/miq/vmdb/log/evm.log


#7

@Karel, It appears to be an issue with self signed certificate provided by proxy. Not sure how to bypass it


#8

Hi,

I have similar issue, my manageIQ server (euwe-1 version) is running behind a proxy and I’m not able to create a new Amazon EC2 provider.

I have tried almost all options:

  • via UI “Configuration - Advanced - http_proxy” : not working (why there is no option for https_proxy?)
  • Update emergency.service with http_proxy and https_proxy : not working
  • Update /etc/environment with http_proxy and https_proxy : not working

ManageIQ always display “Bad username or password”. Can you please suggest a workaround?