Auto approvals for vm request


#1

i am trying to setup auto approval limit on cpus but not having any luck. all my vm requests are auto approved no matted the cpu count i select. i have tagged my user group with auto approve max cpu to 1 and quota to - max cpus to 5. the max cpu quota is working but the auto approval is not. is there another place this should be setup?


#2

Check under the VM porvision approval state machine (provisionrequestapproval) select default -> Max_cpu’s.


#3

setting the default under the vm provision approval state machine works but i would like to have different settings for the different user groups. is that not possible?


#4

@markwedge

Mark,

Old post, but replying just in case.

One option is to change the auto approval state machine for each group in a different profile for the group. You could either set the limits in that state machine if they are the same for different groups or you could create a new method based off of validate_request that is called from the custom state machine. That method could then instantiate a configuration instance for the particular group and default with a .missing method.

Let me know if this is something that you are still interested in and I can provide more detail.