./bin/update failing on update:ui because yarn failed


#1

As of yesterday, bin/update is running yarn in ui-classic.

For some, this means you may need to install it…

npm install -g yarn works, but the yarn official installation instructions recommend adding their repo and installing from there.

For Mac users, brew install yarn works :wink: .

(Our developer setup has been updated.)


When yarn is missing, you should be getting something like this during bin/update:

== yarn failed ==

== Command ["bundle exec rake update:ui"] failed in /home/ncarboni/Source/manageiq ==