Bumping minimum Ruby to 2.2


#1

Hi!

We’re about to update the application to require Ruby 2.2. (#4529)

The appliance has been running on 2.2 for several months, as have many developers, so we know everything works.

If you’re currently using Ruby 2.0 (or 2.1), you should upgrade at your earliest convenience: the Gemfile will start refusing to run on older versions in a couple of days, ready for the Capablanca beta.

Upgrading

There are many variations to how your system might be set up – if you know how to do this, just do whatever will work. If you’re not sure, try one of these…

RVM:

rvm get stable
rvm install 2.2.3
rvm --default use 2.2.3
bundle install

rbenv + ruby-build:

brew update
brew upgrade ruby-build
rbenv install 2.2.3
rbenv global 2.2.3
bundle install

ruby-install:

ruby-install ruby 2.2.3
# update your ~/.bashrc or ~/.zshrc to call "chruby 2.2"
# restart your shell
bundle install

If you still seem to be using the older version (ruby --version), check for a .ruby-version file in the local directory.


#2

rbenv:

cd workspace/manageiq rbenv install 2.2.3
rbenv local 2.2.3 gem install bundler (new version)
gem install nokogiri -v '1.6.6.2' #it fails without doing this bundle install

In Fedora 23, I also needed:

# sudo dnf install graphviz-devel graphviz-ruby

ruby local #shows local version
rbenv install --list #show all version available


#3

Using RVM requires after that also:
gem install bundler -v "~>1.8.4"
otherwise “bundle install” will not work.