Cannot add EC2 cloud provider


#1

Hello,

I have installed manageiq recently, I want to add Amazon EC2 provider to it. But adding it with access key resulted in error like “credentials validation failed: connection refused on 443 for ec2amazon…com” Actually I have to use some https_proxy in server /etc/profile to communicate to outside internet. But in manageiq webinterface, changes are not reflecting. Is it possible to add https_proxy in the configuration?


#2

@gtanzillo can you review this question from @adlinix and forward to a SME if necessary.


#3

Found the solution from(http_proxy) from Karel. however, I am getting SSL error as below :frowning:

“Credential validation was not successful: Unexpected response returned from system: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed”

Can it be anyway related to SSLv3 issues? or Is it possible to avoid connection through SSL and instead connecting via port 80?


#4

Actually, its self signed certificate provided by proxy. How can we make manageiq trust a self signed certificate? Is there any changes can be done on manageiq configurations?


#5

For example, while using wget, we can use the below option to avoid checking the certificate. I am looking for a similar solution in manageIQ. I cant do anything on proxy side as its out of my control and all outgoing traffic flows through proxy itself

===
wget https://ec2.us-west-1.amazonaws.com --no-check-certificate

Anyway to do it?


#6

I fixed the wget issue by uploading the trusted ca in the server, still manageiq appears to be displaying the same error


#7

Hello,

Is there anyway to add our own trusted root certificate to manage iq appliance?

Thanks