Capablanca - SSA on vmware


#1

Hello,

I’ve setup a Capablanca appliance on vSphere environment.
I try to run SmartStateAnalysis but it fails every time.
I’m running the SSA directly from vCenter with no authentication on the hosts themselves.

I’ve tested multiple possibilities and here’s my troubleshooting:

  1. Botvinnik with VixDiskLib 5.5.3 -> works fine on running and shut down virtual machines
  2. Capablanca with VixDiskLib 5.5.3 -> works fine on virtual machines shut down but doesn’t on running vm
  3. Capablanca with VixDiskLib 5.5.5 -> can’t connect to host error. (code 18000)

It seems for me that Capablanca is not triggering the snapshot whereas Botvinnik do on running VMs before analysis.
Here’s the error

Unable to mount filesystem. Reason:[FFI::VixDiskLib::ApiWrapper#open (errcode=15 - VIX_E_FILE_ALREADY_LOCKED): The file is already in use [ESX01-SSD] ManageIQ/ManageIQ.vmdk]

Is there anyone else working with vmware and Capablanca and having this issue?
Regards,
Joseph.


#2

That’s correct. Recent changes introduced this bug - snapshots not being created for SSA on VMware. A pull request has been made for the fix. It should be merged early next week.


#3

Hello,

Has the fix been merged with the Capablanca release? I’ve download the latest version and I still get the same error.

regards,
Joseph.


#4

Hi,

I’ve tried to run “git pull” to get the latest code and it says already up to date.
I checked some files that were supposed to be amended (cf github) but i can’t see the changes.

How do I get the fix?

Regards,
Joseph.


#5

@rpo What is the pull request that fixes this issue? We may need it on Capablanca.


#6

@chessbyte - the pull request is: https://github.com/ManageIQ/manageiq/pull/5549


#7

Hi,

How do I get the change implemented in Capablanca?
I’ve tried git pull on the appliance but it says up to date.
I’ve tried to download the latest devel but there are other bugs in there.

Regards,
Joseph.


#8

I believe this has been backported to capablanca now and should be available in the capablanca-2 release when we release it (should be soon).