Catalog Bundle - Provision Request notification e-mails


#1

Hi there,

I’ve probably missed something really simple here, but hoping you can help. I have created a catalog bundle and set the default approval method to manual.

My “self-service” users can create requests perfectly, but no e-mail is ever sent to an approver or administrator. I have checked the e-mail configuration and sent a test e-mail and this is working perfectly, so something in my configuration must be wrong.

I tried setting valid “to_email_address” and “from_email_address” addresses in a copied instance of /Service/Provisioning/Email/ServiceTemplateProvisionRequest_Pending but no e-mail was sent so I presume this is the wrong place in the Automate model to set them for a Catalog Bundle?

If anyone could help me figure this out it would really speed me along!

With thanks,

James


#2

James,

What version are you using ? Later versions will have a System/Notification/Email class with more than 40 instances.


#3

Hi there,

Thanks for your reply - at the moment I am testing with Red Hat’s CloudForms version - 5.9.6.9

I found the path you mentioned in the Automate Explorer (System/Notifiation/Email) and I see the following instances:

TransformationPlanComplete
TransformationPlanRequestApproverApproved
TransformationPlanRequestApproverDenied
TransformationPlanRequestApproverPending
TransformationPlanRequestRequesterApproved
TransformationPlanRequestRequesterDenied
TransformationPlanRequestRequesterPending

Would these be relevant to sending notification e-mails for an unprivileged user requesting a Service Bundle?

Many thanks!


#4

Is the Notifier role on the appliance enabled?


#5

D’oh - should have spotted that one. I’m having a recurring problem in my browser sessions at the moment - have tried both Chrome and Safari - when I try to turn on the Notifier role, I see the following error:

Edit aborted! CFME does not support the browser’s back button or access from multiple tabs or windows of the same browser. Please close any duplicate sessions before proceeding.

I’ve had this multiple times with this version, and Chrome has been more reliable but it keeps coming up. Very frustrating given that I only have one session open!