Cluster is not an eligible resource for this provisioning instance

automate

#1

I am creating a provision request (request_type => ‘template’), from automation; I set cluster, datastore and appears an error:
Provider, Cluster, host, datastore, template, group are tagged with Provisioning scope/all. I test requesting VM provision dialog from Infrastructure/Compute, usign the same automation method for setting cluster and works fine. So, there is no chance It is an scope error. Please help me to find out a solution.

The following error occurred during instance method <set_resource> for AR object <#<ManageIQ::Providers::Redhat::InfraManager::Provision id: 1000000000095, description: “Provision from [CentOS_7_64bits] to [vm]”, state: “pending”, request_type: “template”, userid: “uid=cliente1,ou=users,dc=cloudcenter,dc=local”, options: {:use_pre_dialog=>false, :request_type=>:template, :initial_pass=>true, :owner_email=>“cliente1@cloudcenter.local”, :owner_first_name=>“Prueba”, :owner_last_name=>“Prueba”, :owner_address=>nil, :owner_city=>nil, :owner_state=>nil, :owner_zip=>nil, :owner_country=>nil, :owner_title=>“NA”, :owner_company=>nil, :owner_department=>nil, :owner_office=>nil, :owner_phone=>nil, :owner_phone_mobile=>nil, :owner_manager=>nil, :owner_manager_mail=>nil, :owner_manager_phone=>nil, :sysprep_organization=>nil, :placement_auto=>[true, 1], :src_vm_id=>[1000000000076, “CentOS_7_64bits”], :miq_request_dialog_name=>“miq_provision_redhat_dialogs_template”, :owner_load_ldap=>nil, :request_notes=>nil, :vm_tags=>[], :customization_template_script=>nil, :dns_servers=>nil, :dns_suffixes=>nil, :root_password=>“v2:{LT1u7OIWdxvxAFbOhdhnWw==}”, :addr_mode=>[“static”, “Static”], :gateway=>nil, :hostname=>nil, :ip_addr=>“127.0.0.1”, :subnet_mask=>nil, :placement_cluster_name=>[nil, nil], :cluster_filter=>[nil, nil], :placement_dc_name=>[nil, nil], :number_of_vms=>[1, “1”], :vm_description=>“creada mediante simulacion”, :vm_prefix=>nil, :provision_type=>[“native_clone”, “Native Clone”], :linked_clone=>[nil, nil], :vm_name=>“andres”, :pxe_server_id=>[nil, nil], :schedule_type=>[“immediately”, “Immediately on Approval”], :vm_auto_start=>[true, 1], :schedule_time=>2018-02-09 14:25:46 -0500, :retirement=>[0, “Indefinite”], :retirement_warn=>[604800, “1 Week”], :stateless=>[false, 0], :vlan=>“VLAN10_ADMIN”, :mac_address=>nil, :disk_format=>[“default”, “Default”], :number_of_sockets=>[1, “1”], :cores_per_socket=>[1, “1”], :vm_memory=>[“1024”, “1024”], :memory_reserve=>nil, :network_adapters=>[1, “1”], :placement_host_name=>[nil, nil], :placement_ds_name=>[nil, nil], :src_vm_nics=>[], :src_vm_lans=>[], :customize_enabled=>[“enabled”], :src_ems_id=>[1000000000035, “RHEV Quito”], :auto_approve=>false, :ws_values=>{}, :ws_ems_custom_attributes=>{}, :ws_miq_custom_attributes=>{}, :requester_group=>“GPcliente1”, :owner_group=>“GPcliente1”, :delivered_on=>2018-02-08 19:28:40 UTC, :pass=>1, :dns_domain=>nil, :vm_target_name=>“andres”, :vm_target_hostname=>“andres”}, created_on: “2018-02-08 19:28:40”, updated_on: “2018-02-08 19:32:55”, message: “Starting Placement”, status: “Ok”, type: “ManageIQ::Providers::Redhat::InfraManager::Provisi…”, miq_request_id: 1000000000103, source_id: 1000000000076, source_type: “VmOrTemplate”, destination_id: nil, destination_type: nil, miq_request_task_id: nil, phase: nil, phase_context: {}, tenant_id: 1000000000023>>
[----] E, [2018-02-08T14:33:12.439671 #54682:5494bc] ERROR – : Q-task_id([miq_provision_1000000000095]) MiqAeServiceModelBase.ar_method raised: : <Resource <1000000000004:TelconetHA1> is not an eligible resource for this provisioning instance.>


#2

The issue is because I set a vlan that is not in the same cluster as the template is.