Connecting to External Postgres Database


#1

Due to our scenario I’m having to go with an “External Postgres Database” configuration instead of using the baked-in version on the EVM.

Is there anything special that I need to do to the ‘vmdb_production’ database on my Postgres Appliance? I can connect but MIQ trys to migrate the internal db and gives me an error.

Do need to create all the tables in the new database?

Any help would be greatly appreciated.

Thanks

Hector


#2

Hi @hectormg, I’ll be looking into the scenario you described.
Before I assume the steps you’ve taken,…can you walk me through what you’ve done so far?
Please be as explicit as possible so I don’t skip a step you’ve taken.


#3

Hey @jprause,

Well, after running my head into several walls and then noticing that there is a newer release I decided to start over and in addition to that have discovered additional information that either I didn’t find or had the patience to read.

REGIONS!!! Ugh…exactly what I’ve been missing.

So now, I have a master database (region 99) sitting in our cloud infrastructure and our corporate MIQ appliance sitting at our office (Region 1). Database is connected but I can no longer access the WebUI of our Region 1 appliance.

Have I done something screwy…again?

Thanks for your help

Hector


#4

@carbonin would you have further insight into what @hectormg is describing?


#5

@hectormg So we have a few specific options set up in the postgresql configuration files.
You can checkout the files here https://github.com/ManageIQ/manageiq-appliance/tree/master/TEMPLATE/var/opt/rh/rh-postgresql94/lib/pgsql/data for that info (ignore the EVM_V5* files)

I would specifically make sure that you have md5 auth set up in pg_hba for the user you entered when setting up the external db in the appliance_console.

If you can get at the database you are probably fine there though.

If you think the UI is the issue I would want to start with the output from systemctl status evmserverd to be sure the UI workers are running and systemctl status httpd to be sure apache is running.

Thanks,
Nick


#6

@hectormg You might also need the guid file from the original appliance.