Dynamic element entry point not visible


#1

Hello,
Trying to create a dialog with dynamic element, and cannot pick correct entry point. The “Select Entry point instance” comes up and I can start expanding tree, but the tree is long enough and the if element I am looking for does not fit into default dialog size, I cannot see a way to scroll down and pick anything below what’s displayed.

Tried with Chrome and Firefox on Linux and Chrome, Firefox and Safari on OSX.
Am I missing something obvious? Is there a way to just type path into the Entry point field?

Thanks!


#2

@dclarizio can you review this question from @sgenchev and forward to a SME if necessary.


#3

@sgenchev Can you let us know which exact release this is on?
@epwinchell Are you aware of this issue either on master or maybe something we’ve fixed recently?


#4

I am not sure how to tell exact version. I am on Capablanca appliance, and completely up-to-date with this git config:
vmdb]# cat .git/config [core] repositoryformatversion = 0 filemode = true bare = false logallrefupdates = true [remote "origin"] url = https://github.com/ManageIQ/manageiq.git fetch = +refs/heads/*:refs/remotes/origin/* [branch "master"] remote = origin merge = refs/heads/master [branch "capablanca"] remote = origin merge = refs/heads/capablanca


#5

@dclarizio Bump… The problem exists in capablanca-2 appliance out of the box. Do you know if there ia a branch where it is fixed?

Thanks!


#6

@epwinchell Can you find the PR or commit reference that fixed this? Thx, Dan


#7

The bug was fixed in this PR: https://github.com/ManageIQ/manageiq/pull/5522


#8

Thank you very much,

Works now for me.