GCE, bad network when making VM


#1

I added an empty project in GCP to ManageIQ. The network named"default" was deleted after I created a differently named network [mynetwork]. When I go to create a new VM from Compute > Clouds > Instances > Images, that always fails because it looks like a network named “default” is being used instead of “mynetwork”. I’ve tried this both with “chose automatically” checked and “Cloud network” set.

[----] E, [2017-08-11T11:53:09.511878 #23941:6f3608c] ERROR -- : Q-task_id([miq_provision_83]) <AutomationEngine> /var/www/miq/vmdb/app/models/mixins/miq_provision_mixin.rb:86:in `block in eligible_resources'
[----] E, [2017-08-11T11:53:09.513309 #23941:b0d8440] ERROR -- : Q-task_id([miq_provision_83]) <AutomationEngine> <AEMethod object_walker> object_walker#C36C8454 (print_associations) - [Provision workflow does not contain the expected method <allowed_cloud_tenants> (MiqException::MiqProvisionError)]
[----] E, [2017-08-11T11:54:28.465151 #14056:1163130] ERROR -- : Q-task_id([miq_provision_83]) MIQ(ManageIQ::Providers::Google::CloudManager::Provision#provision_error) [[Fog::Errors::Error]: Invalid value for field 'resource.networkInterfaces[0].network': 'https://www.googleapis.com/compute/v1/projects/MYPROJECT/global/networks/default'. The referenced network resource cannot be found.] encountered during phase [start_clone_task]
[----] E, [2017-08-11T11:54:28.465272 #14056:1163130] ERROR -- : Q-task_id([miq_provision_83]) /opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/fog-google-0.5.2/lib/fog/google/shared.rb:188:in `build_excon_response'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/fog-google-0.5.2/lib/fog/google/shared.rb:159:in `request'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/fog-google-0.5.2/lib/fog/compute/google/requests/insert_server.rb:251:in `insert_server'
/opt/rubies/ruby-2.3.1/lib/ruby/gems/2.3.0/gems/fog-google-0.5.2/lib/fog/compute/google/models/server.rb:273:in `save'
/var/www/miq/vmdb/app/models/manageiq/providers/google/cloud_manager/provision/cloning.rb:43:in `block in start_clone'
/var/www/miq/vmdb/app/models/manageiq/providers/google/cloud_manager/provision/cloning.rb:42:in `start_clone'
/var/www/miq/vmdb/app/models/manageiq/providers/google/cloud_manager/provision/state_machine.rb:37:in `poll_instance_disks_complete'
[----] E, [2017-08-11T11:55:13.608427 #14056:11605e8] ERROR -- : Q-task_id([miq_provision_83]) <AutomationEngine> <AEMethod update_provision_status> VM Provision Error: [va32lmiq01] VM [awesome01] Step [CheckProvisioned] Status [[Fog::Errors::Error]: Invalid value for field ] Message [[Fog::Errors::Error]: Invalid value for field 'resource.networkInterfaces[0].network': 'https://www.googleapis.com/compute/v1/projects/MYPROJECT/global/networks/default'. The referenced network resource cannot be found.]

Any ideas how to change the network name from “default” to “mynetwork”? Thanks.