How to setup https connection in ManageIQ

ui

#1

I have ManageIQ installed on my Centos server and it’s working fine.
Now I have domain purchased on Godaddy and my website is mapped to my manageIQ Public IP. So Now I want to setup https connection in ManageIQ.


#2

What do mean by installed it on CentOS? People use ManageIQ usually with the Appliance Images by the ManageIQ team. Are you running from source?

ManageIQ should start a webserver on Port 443 by default. Have you verified that ManageIQ is in fact listening on Port 443? If that is the case and you can access it from within the LAN, the problem is likely to be in the network.

If ManageIQ is not running correctly, you might want to take a look at the installation guide
If you are a redhat customer they have more detailed installation guides on their homepage (I think they are even accessible without a subscription)


#3

Thanks for Information Buc.

I have installed centos using Devlopwe setup guide from http://manageiq.org/docs/guides/developer_setup

My ManageIQ is working on http://localhost:3000

Now I want to make it works on https://localhost:3000


#4

I don’t think that mode is really supported for non-development.

That said, I’ll point you at manageiq/lib/miq_environment.rb around line 32 - is_appliance?.

I have found out that when doing development, creating a /var/www/miq/vmdb will make development mode stop working, because is_appliance? implies https cookies, for example.

So that should put you half way there, the other half is setting up Apache / Nginx to deal with the actual SSL stuff.

Then, you’ll just have to deal with all the differences between your environment and what manageiq expects on our appliances.

I’m not saying I’m recommending this, but it should be possible :).


#5

So can you provide us with proper documentation related to this vmdb setup?


#6

That’s a no. I don’t think there is any such documentation.

But if you do figure it out, please share :slight_smile:


#7

Thanks alot himdel.


#8

I got your Point. I have gone through Appliance available from ManageIq download portal. They are HTTPS configured. So How can I make my developer Setup SSl configured like appliance?


#9

Is there any step for ManageIQ appliance environment setup from ManageIQ.


How to setup ManageIQ Devloper Setup environment as an appliance to work on https SSL
#10

Can you explain to us why you need SSL for a developer setup and/or why you cannot use the appliance images? Maybe if we understand what your ultimate goals are, we can help you with that.

The way I see it, you should use the ManageIQ appliance if you are an enduser and the developer setup only if you want to work on the source code (and as a developer you should not need to care about HTTPS)

If you need to migrate data from you current developer setup to an appliance, most objects can be exported via rake tasks and if all else fails dumping the database and restoring it works perfectly fine too

If you REALLY need to turn your developer setup into an appliance, you are probably on your own, as there is no documented way to do it. But you can checkout the configuration on the appliance, as well as the repositories to build them



PS: Let’s stick to one thread for this discussion, please :slight_smile:


#11

Yes sure Buc. I really thankful for your support…

Buc BTW we are working on manage IQ as an developer to develop more features and contribute into Manage IQ community.


#12

That answers why you cannot use the appliance. But I still don’t understand why you need SSL in the first place.
Do you need only encryption? Do you need IPA or external auth (both run over httpd, I think)? does a standard httpd reverse proxy work too?


#13

Actually I had setup a Httpd( Apache server) to proxy/reverse proxy user request from Apache to ManageIQ environment( http://localhost:3000) . But As this is not working right now. My Apache won’t able to pass http proxy request to 3000 port. I don’t understand why. This is what basic thing I had done and Now I understand is I cannot directly forward request to rails env.

So that’s why I was suppose to ask question about how you have done this setup in Appliance mode.


#14

Hey Guys I got same issue regarding proxy settings. It won’t work. Only redirector to 3000 port works but this will not serves through apache. I want to make my connection secure as I am use it to manage my cloud accounts.


#15

I would suggest running an actual manageiq appliance, and copying the apache config from there.

The relevant rules are probably here, but parts of the config are generated by our code, so, the appliance is probably a safer bet.