Issues with creating a catalog bundle and sending values to the AWX playbook

I’ve been trying to follow blog articles and examples on how to create a Catalog bundle with a VM provision followed by an AWX job.

I followed this article - https://cloudformsblog.redhat.com/2017/11/02/cloudforms-service-bundle-creation-using-vm-provisioning-and-ansible-tower-automation-job/

but it does not seem to be passing the values through. If anyone has any guidance or direction on this. I am all ears.

[----] I, [2020-02-24T20:30:03.358928 #4797:4aeda4] INFO – : Q-task_id([r1000000000585_service_template_provision_task_1000000001816]) Starting Ansible Tower Provisioning
[----] E, [2020-02-24T20:30:05.624673 #4797:4aeda4] ERROR – : Q-task_id([r1000000000585_service_template_provision_task_1000000001816]) The following error occurred during instance method <launch_job> for AR object <#<ServiceAnsibleTower id: 1000000000520, name: “AWX-Bundle-Win-Add_AD_Grp_to_Srvr_Local”, description: “Adds an AD domain group to a local group on a svr”, guid: “32b4f00c-cf6c-48ee-b402-13ba18e18fbd”, type: “ServiceAnsibleTower”, service_template_id: 1000000000061, options: {:dialog=>{}, :create_options=>{:extra_vars=>{}}}, display: false, created_at: “2020-02-25 02:28:50”, updated_at: “2020-02-25 02:29:50”, evm_owner_id: 1000000000005, miq_group_id: 1000000000027, retired: false, retires_on: nil, retirement_warn: nil, retirement_last_warn: nil, retirement_state: nil, retirement_requester: nil, tenant_id: 1000000000001, ancestry: “1000000000518”, initiator: “user”>>
[----] E, [2020-02-24T20:30:05.624837 #4797:4aeda4] ERROR – : Q-task_id([r1000000000585_service_template_provision_task_1000000001816]) MiqAeServiceModelBase.ar_method raised: MiqException::MiqOrchestrationProvisionError: <{“variables_needed_to_start”:["‘vm_name’ value missing","‘windows_ad_access_local_group_role’ value missing","‘domain_ad_group’ value missing"]}>
[----] E, [2020-02-24T20:30:05.624946 #4797:4aeda4] ERROR – : Q-task_id([r1000000000585_service_template_provision_task_1000000001816]) /opt/rh/cfme-gemset/gems/ansible_tower_client-0.19.1/lib/ansible_tower_client/middleware/raise_tower_error.rb:21:in `on_complete’

I managed to get the limit value to pass through (I forgot to unset my dialog on the ansible playbook, and disable display).

I am still hitting a brick wall though -

[----] E, [2020-02-24T21:08:23.703671 #4797:dcdbb50] ERROR – : Q-task_id([r1000000000589_service_template_provision_task_1000000001835]) Template Svr-Windows-Add_Domain_Grp_to_Srvr_Local_Grp launching failed. Reason: ‘PROMPT ON LAUNCH’ is required for the following fields: limit (MiqException::MiqOrchestrationProvisionError)

There’s a ‘prompt on launch’ checkbox for the Limit field on the job template in AWX - this needs to be checked for MIQ to be able to override this job-defined limit with the one from the VM provision.

Hope this helps,
pemcg