Limit for Ansible Tower


#1

Hi guys,

I’ve been able to create a service that invokes an Ansible Tower template. While it launches successfully, I have been unable to make use of the limit feature available in the dialog. I was under the impression that by using the limit field, i’d be able to force Tower to run the job on a single host if required. However, this doesn’t seem to be the case. In my play i’ve tried setting the hosts tag to ‘all’ and to a specific group but neither has worked. I obviously can’t remove the hosts tag otherwise Tower won’t read the file as a play.

It would appear that Tower isn’t even using what’s being passed by limit and it’s just using the hosts field in the play by default. What am I missing? Or have I misunderstood the use of the limit option in the dialogue?

I should also point out, that the VM’s i’m running these plays against are not managed by ManageIQ.

Kind regards,

A.


#2

Have you selected Prompt on launch within the job template? See https://pemcg.gitbooks.io/mastering-automation-in-cloudforms-4-2-and-manage/content/running_an_ansible_tower_job_from_a_button/chapter.html#_job_template

Check your Tower jobs to see if limit was passed to the template.


#3

That’s exactly what I missed. Apologies, I overlooked that section as I wasn’t creating a button.

Thank you for your help. Appreciated!

A.