MIQ VMware appliance upgrade howto

Hi All
Thanks for contribution in other forum threads on this upgrade subject, I am putting together following step-by-step google doc. Hope others can review and comment to catch my error.

Thanks

1 Like

Be warned, my second attempt was not successful when doing a Fine-1-Beta2 to Fine-1 upgrade. See https://github.com/ManageIQ/manageiq/issues/15267

Hi,

If you want to migrate for a version to another, I think you should add:
bin/rake db:migrate
bin/rake evm:automate:reset

To ensure that you are using the latest changes.

Not sure, but doing bower update could be great too.

1 Like

Thanks @LorkScorguar for the additional steps. As you can see I am not familiar with the big picture of miq using ruby rail MVC framework.

Thanks @tjyang for sharing…Is there anyway to upgrade from fine-4 to Gapri-3 ?

@anhht4,

The changes between the twos are so much, not sure the bin/update main script can handle it.
Also I personally do not have this need to try (Fine-4 to Gapri-3) upgrade path.
I always do a VMWare snapshot when doing miq upgrade.

Sorry, not an answer to your question.

1 Like

Hi,
Actually I followed up this post for the migration but somehow the web is unavailable afterwards.
Anyway, Thanks for your hints :slight_smile:
BR,
Andy

1 Like

You were advised to use bundle update instead of bundle install but section Upgrade from Gapri-4 to Gapri-5 still has bundle install. Is this intented?

Also I find a little hard to follow the doc. I want to do Gapri4->Gapri5 upgrade: should I read all the doc from beginning or only the section Upgrade from Gapri-4 to Gapri-5?

Hi @xian

In Gapri-x released, I added “bundle clean --force && bundle install” two lines after bin/update line.

Sorry I don’t remembers exact reason, it was from some googling on RoR topic. I think it was to fix the gem outdated messages I encountered after bin/update ruby script.

Hope miq developers can comment if “bundle clean/install” is still needed.

Trying to update from hammer-7 to hammer-9 with this document but I have run into problems.
i get the following error running “bundle exec rake evm:compile_assets”:

[2019-08-07T19:23:51.898223 #30008] INFO – : Writing /var/www/miq/vmdb/public/assets/remote_console-7ba3f2abb00f582822cfb91a56018b46c7eb6c3b1e35a7f79e0c73d7a4902a56.js.gz
rake aborted!
Sprockets::FileNotFound: couldn’t find file ‘@manageiq/ui-components/dist/css/ui-components’ with type ‘text/css’

Any help would be appreciated.