Openstack Icehouse and ManageIQ Issues


#1

I have OpenStack running and manageiq running. I can add my OpenStack cloud and with the latest mangementiq version is doesn’t pick up my instances or images. If I use rc1 it can see my images and instances, but doesn’t allow me to provision new VM’s. I get a pre_prov error. Any ideas? Thanks!


#2

Here is the exact error message:

Unexpected error encountered

Errors in Management Engine can be caused by:

① Accessing Management Engine from multiple tabs or windows of the same browser on a single machine.
Close any duplicate browser sessions, then select a menu option above.
② Pressing the back button during a session.
Close any duplicate browser sessions, then select a menu option above.
③ An internal system error.
Please contact your administrator for assistance.

Error text:

Action not implemented [vm_cloud/pre_prov]


#3

Have the same problem, so any help appreciated


#4

Here’s some snip from production.log

FATAL – : Error caught: [ActionController::RoutingError] No route matches {
:action=>“pre_prov_continue”, :id=>nil, :button=>“submit”, :controller=>“vm_cloud”}
/opt/rh/ruby193/root/usr/local/share/gems/bundler/gems/rails-f9749c2ef83b/actionpack/lib/action_dispatch/routing/route_set.rb:54
0:in raise_routing_error' /opt/rh/ruby193/root/usr/local/share/gems/bundler/gems/rails-f9749c2ef83b/actionpack/lib/action_dispatch/routing/route_set.rb:53 6:inrescue in generate’
/opt/rh/ruby193/root/usr/local/share/gems/bundler/gems/rails-f9749c2ef83b/actionpack/lib/action_dispatch/routing/route_set.rb:52
8:in `generate’


#5

It seems that devel version: master.20140825031156_8a63772
goes nicely beyond that error… looking better, keep on testing


#6

Confirmed, the routing error that you ran into was fixed in this commit:
https://github.com/ManageIQ/manageiq/commit/b3ef7b886a8061d573c4a53f5728ea2d152ec512#diff-6efb9244cb21541f2784b1d329a6c1abR1498

I’m not sure of the schedule for when commits are making it into the various releases, maybe @jrafanie would be able to speak to that?


#7

I semi-regularly upload a nightly build as the “devel” build which @fox indicates fixes the reported issue.

It would definitely make it into the “b” release.


#8

Hi!
Unfortunately this comes after pressing Submit at the end of trying to provision instance:

Error text:
Validation failed: Miq approvals is invalid, Miq approvals is invalid [vm_cloud/pre_prov_continue]

production.log:

FATAL – : Error caught: [ActiveRecord::RecordInvalid] Validation failed: Miq approvals is invalid, Miq approvals is invalid
/opt/rh/ruby193/root/usr/local/share/gems/bundler/gems/rails-8cf411ee95e7/activerecord/lib/active_record/validations.rb:56:in save!' /opt/rh/ruby193/root/usr/local/share/gems/bundler/gems/rails-8cf411ee95e7/activerecord/lib/active_record/attribute_methods/dirty.rb:33:insave!’

Gurus, any idea ?


#9

We literally saw this issue in IRC yesterday. I’ve opened a GitHub issue, and if you have any more details please put them in that ticket. There was a recent commit to remove old code that it turns out may have actually still been used in this particular case. This is not a Openstack Icehouse issue, so technically, is off-topic for this thread.