OpenStack provider fails


#1

Hello together,

I’m running MiQ on OpenStack Kilo and trying to connect to our productive Dev-Test Havana OpenStack environment (RDO powered), but the connection validation fails with the warning message:

Credential validation was not successful: Login failed due to a bad username or password.

Over the AMQP tab with the same admin credetials the validation works.

In evm.log I get the following exception below:

I guess the connection requires SSL, right?

By the way the remote keystone port is 35357 on Havana.

Thanks!

[----] E, [2015-12-29T17:33:47.751246 #2843:d33998] ERROR – : excon.error #<Excon::Errors::SocketError: SSL_connect returned=1 errno=0 state=SSLv2/
v3 read server hello A: unknown protocol (OpenSSL::SSL::SSLError)>

[----] E, [2015-12-29T17:33:47.791741 #2843:d33998] ERROR – : excon.error #<Excon::Errors::Unauthorized: Expected([200, 204]) <=> Actual(401 Unauth
orized)
excon.error.response
:body => “{“error”: {“message”: “The request you have made requires authentication.”, “code”: 401, “title”: “Unauthorized”}}”
:headers => {
“Content-Length” => "114"
“Content-Type” => “application/json”
“Date” => “Tue, 29 Dec 2015 22:33:50 GMT”
“Vary” => “X-Auth-Token”
}
:local_address => “20.0.1.45”
:local_port => 37572
:reason_phrase => “Unauthorized”
:remote_ip => “xxx.xxx.xxx.xxx
:status => 401
:status_line => “HTTP/1.1 401 Unauthorized\r\n”

[----] E, [2015-12-29T17:33:47.791825 #2843:d33998] ERROR – : MIQ(ManageIQ::Providers::Openstack::CloudManager#verify_api_credentials) Error Class=Excon::Errors::Unauthorized, Message=Expected([200, 204]) <=> Actual(401 Unauthorized)