Problem with appliance_console Azure installation

problem running appliance console
sudo: appliance_console: command not found

For a menu, please type: appliance_console
[clouduser@miq-appliance-1 ~]$ appliance_console
/usr/local/lib/ruby/2.4.0/logger.rb:744:in initialize': Permission denied @ rb_sysopen - /var/www/miq/vmdb/log/appliance_console.log (Errno::EACCES) from /usr/local/lib/ruby/2.4.0/logger.rb:744:inopen’
from /usr/local/lib/ruby/2.4.0/logger.rb:744:in open_logfile' from /usr/local/lib/ruby/2.4.0/logger.rb:736:inset_dev’
from /usr/local/lib/ruby/2.4.0/logger.rb:671:in initialize' from /usr/local/lib/ruby/2.4.0/logger.rb:387:innew’
from /usr/local/lib/ruby/2.4.0/logger.rb:387:in initialize' from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/lib/manageiq/appliance_console/logger.rb:18:innew’
from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/lib/manageiq/appliance_console/logger.rb:18:in instance' from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/lib/manageiq-appliance_console.rb:12:inlogger’
from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/lib/manageiq/appliance_console/utilities.rb:44:in db_region' from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/lib/manageiq/appliance_console/database_configuration.rb:214:inregion’
from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/bin/appliance_console:85:in <module:ApplianceConsole>' from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/bin/appliance_console:82:inmodule:ManageIQ
from /usr/local/lib/ruby/gems/2.4.0/gems/manageiq-appliance_console-3.3.2/bin/appliance_console:81:in <top (required)>' from /usr/local/bin/appliance_console:23:inload’
from /usr/local/bin/appliance_console:23:in `’

Errno::EACCES (everything starting with Errno::) is an operating system error. appliance_console tries to create a log file in /var/www/miq/vmdb/log but your user does not have permissions to create a file there.

You should run appliance_console as root, given that many operations in appliance_console need root access anyway. I am not sure why sudo does not work, but appliance_console is located in /opt/rh/cfme-gemset/bin/appliance_console so you should be able to run it from there

1 Like

problem solved with sudo su