Required. Should have privileged access, such as root or administrator in manageiq


#1

I try to monitor hawkular with manageiq on centos 7. These are my monitoring implementation process which are run on root privilege.

First cassandra nosql db is executed.

systemctl start cassandra

And next I execute the hawkular server like below as root

unzip hawkular-services-dist-0.23.0.Final.zip
./add-user.sh -a -u username -p password -g read-write,read-only
./standalone.sh -Dhawkular.rest.user=username -Dhawkular.rest.password=password -Dhawkular.agent.enabled=true

And then, I run docker and related manageiq docker-image.

systemctl start docker
docker pull manageiq/manageiq:euwe-1
docker run --privileged -d -p 8443:443 manageiq/manageiq:euwe-1

I run manageiq on firefox with the following address and it works successfully with user admin and password smartvm.

https://localhost:8443

And I try to add hwakular middleware on manageiq web UI with the menu “Add New Middleware Provider” However error message is shown,

“Required. Should have privileged access, such as root or administrator.”

I cannot understand this error message. Hawkular server and manageiq are run on root priviledge. How can I add hawkular service into manageiq monitoring service?

Any idea will be deeply appreciated. Thanks in adanced


#2

I executed all following commands on root account.

systemctl start cassandra
systemctl start docker

docker pull manageiq/manageiq:euwe-1
docker run --privileged -d -p 8443:443 manageiq/manageiq:euwe-1

But the connection to https://127.0.0.1:8443 failes.

After running docker manageiq container, I execute to acccess manageiq docker container

docker exec -ti CONTAINER_NAME bash -l

On ManageIQ docker container, the following command

machinectl

But no machine returns. ManageIQ seems not to be executed on the container.
The changing the root password and setting ssh keys are needed? And then, what should I do?


#3

I solved it. My OS is windows 10 pro, but hyper-v was deactivated. I activated hyper-v and it worked! :grinning:
Thanks any way