Ruby 2.5.x version greater than 2.5.3 is the only supported ruby on ivanchuk

As of today, ruby 2.5.5 is the latest ruby 2.5.x version and should be installed for use on the ivanchuk branch. For now, we will be testing on travis with the minimum required version, 2.5.3.

Ruby 2.6+ may work but is not supported on ivanchuk.

As of this pull request, we will be cowardly refusing to bundle with anything but a 2.5.x version greater than 2.5.3 on ivanchuk.