Smart State Analysis on Vmware


#1

Hello,

I have installed Vmware 6.0 VDDK and verified that its properly installed. I have added the necessary credentials for ESxi host and smart proxy role is enabled as well.

[root@localhost ~]# ldconfig -p | grep -i vix
libvixDiskLib.so.6 (libc6,x86-64) => /lib/libvixDiskLib.so.6
libvixDiskLib.so (libc6,x86-64) => /lib/libvixDiskLib.so

However, my smartstate analysis on a VM failing with following error and same error in evm.log too. What would be the possible issue? Is there anything else I need to take care while doing it?

===========
Connection to [host(directly):localhost] failed for VM:[] with error [Node (search=<//n1:RetrieveServiceContentResponse> namespace=<{“n1”=>“urn:vim2”}>) not found in XML document <#<Nokogiri::XML::Document:0x85c8890 name=“document” children=[#<Nokogiri::XML::DTD:0x1289000 name=“html”>, #<Nokogiri::XML::Element:0x85c8818 name=“html” children=[#<Nokogiri::XML::Text:0x128bf80 “\n”>, #<Nokogiri::XML::Element:0x128bd28 name=“head” children=[#<Nokogiri::XML::Text:0x128b2c4 "\n ">, #<Nokogiri::XML::Element:0x128ae78 name=“title” children=[#<Nokogiri::XML::Text:0x128a734 “The page you were looking for doesn’t exist (404)”>]>, #<Nokogiri::XML::Text:0x1293104 "\n ">, #<Nokogiri::XML::Element:0x1293d84 name=“style” attributes=[#<Nokogiri::XML::Attr:0x12936b8 name=“type” value=“text/css”>] children=[#<Nokogiri::XML::Text:0x129231c "\n body { background-color: #fff; color: #666; text-align: center; font-family: arial, sans-serif; }\n div.dialog {\n width: 25em;\n padding: 0 4em;\n margin: 4em auto 0 auto;\n border: 1px solid #ccc;\n border-right-color: #999;\n border-bottom-color: #999;\n }\n h1 { font-size: 100%; color: #f00; line-height: 1.5em; }\n ">]>, #<Nokogiri::XML::Text:0x1294d9c “\n”>]>, #<Nokogiri::XML::Text:0x12946d0 “\n\n”>, #<Nokogiri::XML::Element:0x1294270 name=“body” children=[#<Nokogiri::XML::Text:0x129dbcc "\n ">, #<Nokogiri::XML::Comment:0x129d80c " This file lives in public/404.html ">, #<Nokogiri::XML::Text:0x129d244 "\n ">, #<Nokogiri::XML::Element:0x129c998 name=“div” attributes=[#<Nokogiri::XML::Attr:0x129c3e4 name=“class” value=“dialog”>] children=[#<Nokogiri::XML::Text:0x134fca0 "\n ">, #<Nokogiri::XML::Element:0x134fb24 name=“h1” children=[#<Nokogiri::XML::Text:0x134f304 “The page you were looking for doesn’t exist.”>]>, #<Nokogiri::XML::Text:0x134eb20 "\n ">, #<Nokogiri::XML::Element:0x134e6d4 name=“p” children=[#<Nokogiri::XML::Text:0x1351668 “You may have mistyped the address or the page may have moved.”>]>, #<Nokogiri::XML::Text:0x135121c "\n ">]>, #<Nokogiri::XML::Text:0x1350bb4 “\n”>]>, #<Nokogiri::XML::Text:0x1350290 “\n”>]>]>>] after [0.464692223] seconds


#2

Feels like it’s the authentication issue with your ESXi host. So you added ESXi host as VMWare provider in your appliance, right? Did you click the validate button before save? if it won’t work, can you try SSA again with the flag of scan_via_host in Setting -> advance?


#3

No, I have added vcenter user in appliance and validated the credentials of the host section. scan_via_host is already true.


#4

@hsong. It got fixed, I had to change the hostname from localhost to the IP of the ESXi host