[Solved] Problem with new EMS Cloud


#21

Hi Ladas,

Thank you so much for your support. Adding a description to two Security Groups that didn’t have one, solved the problem.

Good to know that it will be fixed.

Regards,
Alex.


#22

Hello,

First of all, sorry to get back to this old conversation, but I think it is the right place to ask for the following:

We did some changes in our OpenStack CLoud Provider, changing the Keystone endpoints so now the publicURL enpoints are actually public URLs instead of private ones as in the internalURL endpoints. This made MIQ stop retrieving EVM info, as in our deployment, MIQ can’t access OpenStack services through the public endpoints, but the internal ones.

I could fix this thanks to comment [Solved] Problem with new EMS Cloud in this thread. I added the line :openstack_endpoint_type => 'internalURL' as indicated by @eprsaad. So, EVM refresh works now as expected, the OpenStack inventory is retrieved correctly. However, when I try to deploy an instance, I’m still seeing in the fog logs I set up in debug mode, that it is still trying to reach OpenStack compute service through the public URL instead of the internal one. So, Instance deployment fails with error:

ERROR – : Q-task_id([miq_provision_12]) excon.error #<Excon::Errors::SocketError: getaddrinfo: Name or service not known (SocketError)>

I see it tries to reach:

DEBUG -- : Q-task_id([miq_provision_12]) excon.request
{:uri=>
  "http://openstack.mydomain.com:80/compute/v2/33b98abce3b540cdaf1a333f221a4c5e/servers.json",
 :method=>"POST",
 :headers=>
  {"User-Agent"=>"fog/1.28.0 fog-core/1.31.1",
   "Content-Type"=>"application/json",
   "Accept"=>"application/json",
   "X-Auth-Token"=>
    "MIIPFwYJKoZIhvcNAQcCoIIPCDCCDwQCAQExDTALBglghkgBZQMEAgE ... 

Is there any other file to be edited so I can indicate to always use the internal endpoint instead of the public one? Maybe it hasn’t updated somewhere in the DB the new change and it is still accessing the old endpoints?

I’m really struggling with this, any help will be very welcome.

Thank you!


#23

It seems that stopping the EVM and starting it again fixed the issue. I should have tried that before.

Anyway, I hope my post helps anybody facing the same issue.