The role Embedded Ansible has started activation on server EVM


#1

I have recently enabled the Embedded Ansible role but it keeps showing the following event every few seconds.

“The role Embedded Ansible has started activation on server EVM”

I have tried searching for assistance for this issue but been unable to find anything…any suggestions?

We are running version / build - gaprindashvili-4 on a VMware ESXi 6.5 platform.


#2

Try the KB method:

Disable the Ansible role.

systemctl restart evmserverd #to be sure memory is freed up
rm /etc/tower/SECRET_KEY
vmdb
bin/rails r 'MiqDatabase.first.ansible_secret_key  = nil'
bin/rails r 'MiqDatabase.first.ansible_database_authentication.destroy'
bin/rails r 'ManageIQ::Providers::EmbeddedAnsible::Provider.first.destroy'
psql -d vmdb_production -c 'DROP DATABASE awx' # run on the db appliance
psql -d vmdb_production -c 'DROP ROLE awx' # run on the db appliance

Login to to the UI and enable Ansible role
Check /var/log/tower/setup-.log for status


#3

Hi Xian.

Many thanks for the suggestion but it has not helped.

There is no folder called /etc/tower/SECRET_KEY on the server.

After further investigation it seems as if the MIQ appliance is not able to pull down the docker image.

We are using a proxy for web access and that has been configured within the advanced settings, web access is working as I can access AWS and Azure from MIQ.

The error within the EVM.Log file is:-

ERROR – : MIQ(EmbeddedAnsibleWorker::Runner) ID [14] PID [11801] GUID [xxxxxxxxxxxxxx] No such image: rabbitmq:3