Update your ruby versions for ManageIQ


#1

We will be updating our ruby support on the various release branches so please ensure you have the versions below installed.

For example, ruby 2.5 will be added to 2.4 for travis testing on manageiq’s master branch and 2.3 will be removed here.

What this means:

  1. We’ll be testing with only a single ruby on travis on branches that are released or about to be released.
  2. We’ll be raising an exception if you try to bundle on a branch using an unsupported ruby.

Master:
You’ll need to have ruby 2.4 locally to bundle and ensure tests pass with ruby 2.5 on travis soon.

Hammer:
Minimum ruby is 2.4.

Gaprindashvili:
Minimum ruby is 2.3.

Therefore, it’s greatly recommended to have ruby 2.4, 2.5, and 2.3 locally. Ruby 2.6 was released last month and adventurous developers can try it out and report any bugs we have with it.

We are going through each repository related to manageiq and updating their ruby support, starting with .travis.yml changes mentioned in step 1 above. I will send a followup talk article before we force developers to upgrade their ruby environment described in step 2 above.