Why can't I specify the cloud tenant in I create the virtual machine through the service item


#1

I’m working manageiq-openstack-darga3

I have a service item to provision openstack instances, This is the service dialogs


this is service item Provisioning Entry Point

This is parameters of the create

I make sure I fill parameters are correct, but when I add the cloud tenant service create will fail, like this

Other parameters, like flavor, retirement, root password…Is success. am i wrong ?

I used object walker to debugging.

Who can help me?

Thank!


#2

Hi @anyisalin,…let me see if I can replicate what you’re seeing.
Thanks for the screen shots,…that sure will help.
I’ll be back shortly.


#3

@anyisalin When you created the catalog item type, what was the type that you selected? As for the service dialog that you took screenshots, did you create it from scratch?

It seems you intended to provision an instance in OpenStack. You should select OpenStack for the catalog item type. You don’t need to create a complicated service dialog like you showed because the Request Info tab already provides a dialog for your input to select template, IP address, cloud tenant etc.


#4

I know to this setting, but i have multi cloud provider, i need a general service item to provision openstack instances.
Thank


#5

So you selected the catalog item type as Generic, right? Because the error is raised by the state machine’s CheckProvisioned step, it should have nothing to do with the cloud_tenant field in your service dialog, unless you have modified the CheckProvisioned script. We need to see the log (automate.log and evm.log) and any automate script you have created/edited.


#6

my service type is openstack

Thank


#7

At last I through $evm.root['miq_provision].set_cloud_tenant() set cloud_tenant in automate, but thank you very much