Adding support for ruby 2.4 and dropping 2.2

Hello all,

tl;dr: Install ruby 2.4.1 for your work on the master branch.

Now that the fine branch has been created, we can start working on the next release, and upgrading our ruby is a “fine” thing to start with… :laughing:

Up until now, we have been supporting ruby 2.2 and 2.3 but only testing 2.3 on travis and the bot using ruby 2.2 for syntax.

In the near future, we’ll be supporting ruby 2.3 and 2.4 on master and dropping 2.2. Travis will be testing 2.4, while the bot will be updated to use ruby 2.3 for syntax.

Note, manageiq master already supports ruby 2.4 via this pull request, so now is the time to use 2.4 on master and get all of our libraries 2.4 compatible.

The timeline and work items remaining can be found here.

One work item above worth highlighting is we’ll have to upgrade our webmock version for ruby 2.4 support. As far as I can tell, this will require us to rerecord some VCR cassettes in the main repo but also in the various provider repos using VCR.

Please review the work items above, add missing tasks, and reach out if you can work on any of them or offer other help. Let’s discuss in the core gitter channel.


Update: Adding Ruby 2.4 and dropping 2.2 on Wednesday, October 4th

Hey everyone,

Our summer rearchitecture plans meant this was put on the backburner but we’re back on track and work to support Ruby 2.4 and drop 2.2 support is nearing completion. You can view the progress of this effort, as mentioned above, here.

We’d like to announce officially the end of Ruby 2.2 support on Wednesday, October 4th (two weeks from now). If you’d like to see the gritty details of what happens on this date, see the related issue (above).

For developers working on ManageIQ the jist is that we highly recommend you begin using the latest 2.3.x or 2.4.x over the next two weeks.

If you have any questions or concerns, feel free to contact the platform team in our Gitter channel.

Thank you!
@chrisarcand and @jrafanie


Bumping to just remind everyone that this is happening tomorrow, so if you are still using Ruby 2.2, please upgrade ASAP.

Ok, it’s done. The master branch will now complain if you try to bundle with ruby 2.2.x. Please use ruby 2.3.1+ going forward. Thanks @chrisarcand for finishing it up!

I want to update the manageiq-development-vagrant. Should I use 2.3.3?
I am thinking also in moving it to CentOS to get closer to the build, as currently Fedora 25 is out of date and updating it will also update Postgresql to 9.6.

What do you think?

Ruby 2.4.2 is out. Should we use that? You say latest 2.4 but it would be great to know if there is any minor version involved

Ruby 2.3.1 is still the officially supported Ruby version on appliances for the Gaprindashvili release. This is largely in part to the latest version of Ruby in SCL being 2.3.1.

Ruby 2.3.1 is still the current one on master, though on master we also support the latest 2.4.x for developers to use.

When SCL releases a new version we will update, unless we decide to start packaging our own Ruby, which is also being discussed.