Adding VCloud Director Provider 9.7 fails

Adding VCloud Director Provider 9.7 fails with the below error.

Validation failed: Unexpected response returned from system: The request has invalid accept header: . Supported API versions are: [32.0, 31.0, 30.0, 29.0, 28.0 [D], 27.0 [D], 26.0 [D], 25.0 [D], 24.0 [D], 23.0 [D], 22.0 [D], 21.0 [D], 20.0 [D]] ([D] indicates deprecated versions)

Logs:

[----] I, [2021-07-28T21:05:24.031892 #2624:2ad8f502b964] INFO – : Q-task_id([job_dispatcher]) MIQ(InfraConversionThrottler.pending_conversion_jobs) Pending InfraConversionJob: 0
[----] I, [2021-07-28T21:05:24.033559 #2624:2ad8f502b964] INFO – : Q-task_id([job_dispatcher]) MIQ(InfraConversionThrottler.running_conversion_jobs) Running InfraConversionJob: 0
[----] I, [2021-07-28T21:05:24.037153 #2624:2ad8f502b964] INFO – : Q-task_id([job_dispatcher]) MIQ(JobProxyDispatcher#dispatch) Complete - Timings: {:v2v_dispatching=>0.0018377304077148438, :v2v_limits=>0.0016531944274902344, :pending_container_jobs=>0.0012981891632080078, :container_jobs_to_dispatch_count=>0, :container_dispatching=>0.0013151168823242188, :pending_vm_jobs=>0.0004017353057861328, :vm_jobs_to_dispatch_count=>0, :total_time=>0.00616765022277832}
[----] I, [2021-07-28T21:05:24.037471 #2624:2ad8f502b964] INFO – : Q-task_id([job_dispatcher]) MIQ(MiqQueue#delivered) Message id: [142437], State: [ok], Delivered in [0.006959783] seconds
[----] I, [2021-07-28T21:05:24.080449 #2571:2b123d253968] INFO – : MIQ(MiqGenericWorker::Runner#get_message_via_drb) Message id: [142438], MiqWorker id: [69], Zone: , Role: , Server: , MiqTask id: , Ident: [generic], Target id: , Instance id: , Task id: , Command: [MiqQueue.check_for_timeout], Timeout: [600], Priority: [90], State: [dequeue], Deliver On: , Data: , Args: , Dequeued in: [3.313476343] seconds
[----] I, [2021-07-28T21:05:24.081357 #2571:2b123d253968] INFO – : MIQ(MiqQueue#deliver) Message id: [142438], Delivering…
[----] I, [2021-07-28T21:05:24.084525 #2571:2b123d253968] INFO – : MIQ(MiqQueue#delivered) Message id: [142438], State: [ok], Delivered in [0.003212093] seconds
[----] I, [2021-07-28T21:05:24.100861 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqGenericWorker::Runner#get_message_via_drb) Message id: [142439], MiqWorker id: [68], Zone: , Role: [ems_operations], Server: , MiqTask id: [505], Ident: [generic], Target id: , Instance id: , Task id: , Command: [ManageIQ::Providers::Vmware::CloudManager.verify_credentials?], Timeout: [600], Priority: [100], State: [dequeue], Deliver On: , Data: , Args: [{“endpoints”=>{“default”=>{“hostname”=>“100.70.147.236”, “port”=>443}}, “authentications”=>{“default”=>{“userid”=>“Administrator”, “password”=>"********"}}, “type”=>“ManageIQ::Providers::Vmware::CloudManager”, “zone_id”=>“2”, “api_version”=>“9.0”, :task_id=>505}], Dequeued in: [2.719517016] seconds
[----] I, [2021-07-28T21:05:24.101338 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqQueue#deliver) Message id: [142439], Delivering…
[----] I, [2021-07-28T21:05:24.102579 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqTask#update_status) Task: [505] [Active] [Ok] [Task starting]
[----] E, [2021-07-28T21:05:24.907918 #2563:2b1b8ad7f96c] ERROR – : MIQ(MiqQueue#deliver) Message id: [142439], Error: [Unexpected response returned from system: The request has invalid accept header: . Supported API versions are: [32.0, 31.0, 30.0, 29.0, 28.0 [D], 27.0 [D], 26.0 [D], 25.0 [D], 24.0 [D], 23.0 [D], 22.0 [D], 21.0 [D], 20.0 [D]] ([D] indicates deprecated versions)]
[----] I, [2021-07-28T21:05:24.908333 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqQueue#delivered) Message id: [142439], State: [error], Delivered in [0.806972988] seconds
[----] I, [2021-07-28T21:05:24.911179 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqQueue#m_callback) Message id: [142439], Invoking Callback with args: [“Finished”, “error”, “Unexpected response returned from system: The request has invalid accept header: . Supported API versions are: [32.0, 31.0, 30.0, 29.0, 28.0 [D], 27.0 [D], 26.0 [D], 25.0 [D], 24.0 [D], 23.0 [D], 22.0 [D], 21.0 [D], 20.0 [D]] ([D] indicates deprecated versions)”, “nil”]
[----] I, [2021-07-28T21:05:24.911608 #2563:2b1b8ad7f96c] INFO – : MIQ(MiqTask#update_status) Task: [505] [Finished] [Error] [Unexpected response returned from system: The request has invalid accept header: . Supported API versions are: [32.0, 31.0, 30.0, 29.0, 28.0 [D], 27.0 [D], 26.0 [D], 25.0 [D], 24.0 [D], 23.0 [D], 22.0 [D], 21.0 [D], 20.0 [D]] ([D] indicates deprecated versions)]
[----] I, [2021-07-28T21:05:25.171386 #2673:2abe38a80d38] INFO – : MIQ(ManageIQ::Providers::Vmware::InfraManager::Inventory::Collector#process_update_set) EMS: [BANONE-vCenter6], id: [2] Processing 1 updates…
[----] I, [2021-07-28T21:05:25.172091 #2673:2abe38a80d38] INFO – : MIQ(ManageIQ::Providers::Vmware::InfraManager::Inventory::Collector#process_update_set) EMS: [BANONE-vCenter6], id: [2] Processing 1 updates…Complete

@team, Anyone can comment on this?..

@gmaghesh I don’t know if 9.7 is supported by the fog-vcloud_director gem (GitHub - xlab-si/fog-vcloud-director: Fog for Vmware vCloud Director)

Looks like 9.0 is the most recent API version that we show as supported, if you wanted you could test the fog-vcloud_director gem with the version of vCloud Director you have you could try passing in the more recent api version and see if it works.

1 Like