Ansible Tower Provider

I have added my ansible tower as a provider under configuration. I verified the connection and it’s status is listed as “valid”. However when I click on it, it just says “No records found”. I have run the refresh relationships and still nothing shows up in either the configured systems, or job templates.

One thing that is strange is that last refresh date doesn’t show a value, so maybe the refesh is failing?

Thanks in advance.

@bdunne can you review this question from @Krys_Allen and forward to another SME if necessary.

Hi @Krys_Allen, have you checked the logs? This provider logs to /var/www/miq/vmdb/log/evm.log

I just checked that log and this 3 lines are repeated constantly

[----] I, [2016-11-16T09:20:15.174410 #3045:104f974] INFO – : MIQ(MiqReplicationWorker::Runner#process_alive?) MIQ(MiqReplicationWorker::Runner) rubyrep Process with pid= is not alive pid_state=
[----] I, [2016-11-16T09:20:15.186200 #3045:104f974] INFO – : MIQ(MiqReplicationWorker::Runner#check_replicate) MIQ(MiqReplicationWorker::Runner) Replicate Process gone. Restarting…
[----] E, [2016-11-16T09:20:15.199550 #3045:104f974] ERROR – : MIQ(MiqReplicationWorker::Runner#start_replicate) MIQ(MiqReplicationWorker::Runner) Replication configuration is invalid.

not sure if that is part of the problem or not.

@Krys_Allen That error is not related.

Here is a snippet from the log right after I run the refresh Error Log

Hi, i am actually having this same problem today in Hammer10 and tower anyone aware of the reason for this? Hammer9 and tower - no issues.

Take a look to the zone assigned to the provider, if the provider it is assigned to a Zone in which there are no ManageIQ appliances happens this. The provider is validated but it is not working.
I hope it helps.

they are both in the default zone, but still no luck. the ansible tower log shows the URLs and i can see the templates / job etc… when i follow the link to the API but there is just nothing showing in manageiq.

@Krys_Allen did you check whether your stored password in the provider settings is up to date?