Cannot add item to service catalog

So I cant add an item to the service catalog for an EC2 instance? No errors are being thrown just cant add an item its greyed out. I’m able to provision the instance manually.

Can you provide more detail? Do you have a AWS provider defined? Does the provider have images that are available to the account being used to bind to the provider? thanks

The AWS provider is defined and the images is presented. I tried removing the provider and adding it back. I’m in the process of validating the service account/privileges. Thanks

If the problem persists let us know what version you are running so we can test it out.

So the problem persist after removing/adding the Amazon cloud provider.


I was able to create a catalog item in my local dev environment, so I setup a master.20141121171508_2f1ec4b appliance and can reproduced it there. Looks to be an issue with any catalog item as I tried a generic item and hit the same thing.

Here’s a screenshot showing the “Add” button disabled.

@dclarizio should be able to help resolve this.

I pulled an older version and I’m able to add a catalog item as well

This should be fixed in the latest builds, PR with the fix is