Chargeback Reports Showing Empty....tried many different ways still cannot get through

Hello Friends, Help needed. I have already read the existing posts. still could not help myself.

I created the chargeback rates.

I want to create a report and show it on the dashboard.

I have tried different ways using the filters in report and in the chargeback I have assigned the to the company tags, tenants, enterprise, selected providers etc still could not display the report.

I have enabled all the required metrics in server control and also enabled the C&U in the Configuration->CFME region.

What could go wrong? possibly. I have been trying it from last 48 hours, could not get through. Help me.

1 Like

Sometimes the data used for chargeback is empty, you need to find the right field. Look at the examples in the appliance (and search the web)

It also may help to start by adding all possible fields to the report and see if you’re getting any data out.

Hello Sergio,

thanks for the reply.

Do you have any ideal samples of compute and storage charge back sheets? what exactly to fill in the each field??

Hello gtanzillo,

It is so nice to see the reply from you.

I would like to get the perfect chargeback sheets from you? if possible or at least guide me to create one.
Here are my sample chargeback sheets sample check them out? And let me know where I Am going wrong.

I wish you could refer to the images replied to @gtanzillo And let me know where exactly I am going wrong?

The rates look ok and it looks like you assigned then to the enterprise (from your initial description), which is the most direct way to ensure that you are getting rates.

So you are not getting any report results at all, an empty report? If so, it could either be that no rates are getting selected or there are no available metrics for the report period.

So, what could be the possible solution for those?

@geek-man, I think it will require some troubleshooting to understand what’s going wrong.

To verify whether there are metrics being found within the report range you can look for a log message like this in the evm.log file -

[----] I, [2018-03-19T17:16:16.545714 #23957:3fc8bb2e719c]  INFO -- : MIQ(Chargeback::ConsumptionHistory.for_report) Found 12345 records for time range [2018-02-01 00:00:00 UTC, 2018-02-28 23:59:59 UTC]

If you don’t find that message in the log, that would mean that there are no metrics matching the report options. If you do see that message then the issue is likely to be that no rates were selected for the managed resources in the report. In that case, you’ll need to double check the rate assignment. The best thing is to assign your rates to the “Enterprise” until you are able to get some report results.

Hey Thanks Everybody,

C&U Workers were able to produce the reports finally. The problem was the swap memory exceeded 60%. I doubled the swap memory, now it is all fine.

What I got to know is:
swap memory >> 60%, then no new workers allowed to function.
swap memory >>80%, then existing workers also stop functioning.

This might help you.

Thank you guys once again for your valuable information.

Geek-Man :slight_smile: