Cloud Providers

Hi, I’m having issues setting up cloud providers in gaprindashvili-2.20180305154841_5bba686.

two different problems with two providers.

AWS I configured a provider type region correct and created its own zone. I have tried two users, my root account first and then tried creating a new user with power user security role have the keys, have tried both users, they validate, my provider is created - I only have one instance and one vpc, but it shows nothing, no instances no security groups, nothing. This seems pretty simple, not sure what I could be doing wrong. I have not setup the AWS Config service yet… but I assumed I would get some info back from my account once I setup the provider.

GCP I have a project and an instance, I created a service account in the project gave it owner downloaded the json put it in the box and validate… I get: Credential validation was not successful: Not Found - have tried two different service accounts and same error message.

Would appreciate any advice on either or both of these problems. Seems straight forward to setup in the documentation and no mention of these sorts of problems.


About your AWS problem: manageiq instance and AWS provider must be in the same ManageIQ zone in order to give you info.

As to GCE: see "Not Found" error when trying to add GCE provider
In short: there is a fix, but it is not in master branch for Manageiq core.

thanks, that fixed my AWS problem