Configure External Database, ManageIQ server not running

Hi everyone,

I’m a novice

I have an manageIQ appliance deploy on Vsphere, and i want use an external DB, so i follow the documentation and fill field with my settings.

Once i come back on the summary Information, nothing change so i tried to restart the appliance, from the appliance_console and the ManageIQ server doesn’t run.

So i tried to see what’s wrong with :

journalctl -xe

systemctl status evmserverd.service
debug1

journalctl -u appliance-initialize

If someone had the same error, i resolve this with auth_fix !

i do this step and manageiq is up again :

  1. fix_auth --key

  2. Reset passwords to use current key: `fix_auth --db --invalid yourpassword

  3. fix_auth --databaseyml --password yourpassword

if you want more details i follow this topic Setting Centralized Administration

Know i have another issue, when i try to configure my db if i select :

  1. Configuration Application

and then 2) Create Region in External Database or 3) Join Region in External Database

The configuration seems to be successful but once i got the summary i have this :
errordb

So in the field ManageIQ Database i have the right host but Local Database still running and said primary, Database/Region doesn’t change aswell and once i go in my external database only two table was created : ar_internal_metadata and schema_migration

So i’m lost i don’t know what to do, i keep search on internet without success and the official documentation isn’t quite the same as the reality so it’s disturbing for me.

So i’m gonna reinstall from scratch, maybe i forgot something but if someone can provide me a clear explanation of which steps doing to configure the external database

@Joe_Vlcek Can you help out @Gregoire here?