Dashbord widgets - only text

On capablanca RC2. On dashboard there is "Invalid chart data. Try regenerating the widgets. " or only text data (say for recently discoverd VMs, there are correct VM names). The graphic parts are missing.

Is the issue know (and will be fixed in final release), or is that only ‘my’ problem?

I’m having exactly the same problem (on Capablanca RC1 and RC2, didn’t have it on Botvinnik)…

I can see charts on other sections (example: Reports > All Reports > Configuration Management > Virtual Machines > Guest OS Information - any OS).

In case it is relevant: the C&U data seems to be collected. Say for RHEL/OVirt VM and VMWare, I get graph with CPU and memory usage for CPU, memory etc (for hourly interval at least; but not for daily - not enough time passed since addig VMs/providers?).

And as @jsribeiro said, report for ‘Guest OS Information’ contains valid data and graphs. But on dashbord, widget ‘Guest OS Information’ contains only ‘Invalid chart data. Try regenerating the widgets.’

Is there any progress on this issue?

I have the same problem -> all graphical widgets are like this one:

But if I click on the options (three dots in the upper-right corner) and choose “zoom in” or “full screen” the graph magically appears (only when these two modes are in use). Like here:

The widget on the dashboard stays the same (without graphics) when zoom-in or full-screen views are closed.

I’m really interested in the solution. The Dashboard looks so sad without the graphs :wink:


Solution here

Thanks! I tried editing:


adding the “.to_yaml”, restarted the appliance but still no graph. What am I doing wrong?


Thanks @laurodias! It works for me.

@bongo, you need to manually re-generate widget content or wait for the next schedule that will generate the content. For manuall go to Cloud Intelligence -> Reports -> Dashboard widgets -> Charts -> … here choose each Chart Widget and initiate content re-generation (Configuration -> Generate Widget content now).