Data not pulled from my OpenStack Cloud Provider


Since I added my OpenStack Cloud Provider to my ManageIQ installation, I haven’t been able to retrieve all the information I was expecting to pull out from that platform:

OS is unknown for all instances and a lot of information is missing.

I did the following a couple of hours ago, after doing some research about what could be happening with my installation:

Collecting Capacity and Utilization (C&U) Data

Go to Configure-Configuration-Settings-Zones-Servers.
Enable all C & U Roles from the Server Roles section.
Click Save. (It will take a few minutes for the roles to start).
Go to Configure-Configuration-Settings-Region-C & U Collection.
For Cloud Providers, check Collect for All Clusters.
For Infrastructure Providers, check the required Clusters and Datastores.
Click Save. It will take some time for the data to collect and process.

Still no luck :frowning:

Could anybody tell me what am I missing? Thank you in advance.


@blomquisg @Ladas Can you help out here?

Seems like openstack does not expose operating system name (instance) in any
inventory data Therefore, Cloudforms cannot pull OS info and mark it as unknown.
I see operating system name showing correctly for VMs on VMware and RHEV providers.

To fetch other information like users, groups, configuration files you have to run
smart state analysis. (On instance detail page, Click Configure → Perform SmartState Analysis.)

For more information about smart state analysis aka VM Fleecing see :


So is it not possible to retrieve OS info from an OpenStack Cloud Provider?
I tried to perform Smart State Analysis in a couple of instances but no luck either:

Am I missing anything yet?


@Alex currently OS is not collected, we are tracking RFE for that . So at some point it could land in smart state analysis.

Hi Ladas,

Thank you for your reply. So, Smart State Analysis is actually working, it is just that OS data won’t be collected from an OpenStack Cloud Provider for now, right?

It is difficult to show useful information in the Dashboard, reports, etc. without retrieving OS information from the instances … Any recommendation?


@Alex maybe @blomquisg will know. Is it possible to somehow leverage Images relation here? Nothing else crosses my mind.

Thanks @Ladas I will wait for @blomquisg reply.

Hi @Alex

I was digging through one of our OpenStack test environments today trying to figure out if there’s a way to get this information from the API.

I don’t see one yet, but I have to believe it’s there somewhere :confused:

@rpo, can you elaborate a little on how @Alex might collect operating system information through smart state in OpenStack? If that’s even an option. Thanks!


Hi @rpo,

Any thoughts? I am still hoping there is something I can do about this.


By default, OS and distribution information is collected via SmartState. SmartState is guest-specific - not provider-specific - so, if it’s collecting it for other providers, it should for OpenStack as well. Do you know if the SSA is completing successfully? You can track the state of the job via : configuration->tasks.

Hi @rpo,

Thank you for your reply, much appreciated.

I did a Smart State Analysis for an instance and I can see the state of the job where you suggested, but SO is still displayed as unknown and all OS related data is missing:

The displayed message for the job says that SSA was not completed because the Cloud Provider could not create a snapshot. What kind of snapshot are we talking about? Any idea on how to solve this issue?

Unfortunately I don’t have any Infrastructure Provider or additional Cloud Provider to compare my OpenStack Cloud Provider to.

Thank you very much for your support.


In order to scan a running instance, we take an image snapshot, scan that, and then throw the image away. For some reason it can’t create that image snapshot. @rpo Do you need anything from @Alex to determine the problem?

Hi @rpo and @Fryguy,

I deployed an instance to try to get results from a Smart State Analysis and at least, I can see the mentioned Snapshot:

I’m going to wait to see if I get further information for that instance and will let you know.

Looking at the logs, I realized that there are many errors complaining about OpenStack having no metering service, which is true for our OpenStack development platform.
Is it required for ManageIQ to have the ceilometer service installed in an OpenStac Cloud Provider? Which ManageIQ features could be affected if there is no metering service?


Ok, so I realized that the Snapshot is being stored in my ManageIQ machine under /tmp, which right now is way too small to store an image of any instance. That’s why it fails, dumping the corresponding error in the fog.log

I thought ManageIQ would use the storage where Glance stores de images for that Snapshot. Does it really make sense to have a big enough /tmp partition to allocate several simultaneous Smart State Analysis temporary images?

Please, provide some comments about this and the Ceilometer issue and we will make the required changes on the platform in order to move forward with this.

Again, thank you for your support.


It’s not that ManageIQ creates the snapshot image in /tmp, but it has to download it there so it can be analyzed. This is because the Glance API doesn’t (yet) permit downloading of parts of the image. Given the need for a larger /tmp is specific to OpenStack SSA - it has not been made larger by default.

I can’t speak to the Ceilometer issue.

@blomquisg Can you comment on the Ceilometer issue?

Understood @rpo, thank you. Any commments on the Ceilometer issue @blomquisg ?

Hi @Alex,

Ceilometer is not required, and the appliance shouldn’t be trying to access Ceilometer if you don’t have Capacity & Utilization enabled in the Appliance Configuration.

However, if you don’t have Ceilometer and metering, then the features affected are charting usage metrics, alerts, and utilization events (i.e., if VM CPU usage > 80%, run an automate script that can balance workload). There’s probably other features that can tie into utilization data. @jhardy, do you have a list of any other features tied to Cap&U that would be affected by not collecting metering data?

I have miq integrated with MOS 6.1. How long does it take for C&U start showing data? I have enabled it for some hours but all graphics show “”.

Also when I ask for a SmartState analisys it’s task stays in waiting_to_start until a timeout error happens.