Datamodel instance breaks after edit?

I have edited the body field in the System/Notification/Email/ CloudMiqProvisionRequestRequesterPending instance and now it simply doesn’t send an email at all when I submit a request. What am I doing wrong?

first I changed:
<a href=${/#miq_request.show_url}>${/#miq_request.show_url}</a>
<a href=${/#miq_request.show_url}>${/#miq_request}</a>
(I did that to see the miq_request object to see what other properties it might have. All I got in the email was a “#”.)

So I changed it to:
<a href="">click here</a>.

After making this change, ManageIQ stopped sending pending approval emails to the requester altogether.

I have tried all of the following to revert to the original, but it still doesn’t send an email when I submit a request:

  • I restored the original content in the body field,
  • I tried removing my copy of the /System/Notification namespace and it’s classes and instances altogether
  • I tried re-copying the class and instance afresh from the locked domain.
  • I also tried stopping and starting the EVM Server Process from the Appliance Console.

And yet the system will not send me a pending approval email when I submit a request.

I looked in automation.log for errors and found:
Class [Discovery/ObjectWalker] not found in MiqAeDatastore
No errors in evm.log

Any idea why it won’t send an email anymore?

It looks like somewhere in your workflow you’re calling Discovery/ObjectWalker/object_walker, but this doesn’t exist in your datastore (or maybe the Investigative_Debugging domain is disabled if you’ve downloaded it). This will terminate your workflow or state machine, and might explain why the emails aren’t being sent.

Have a look for a call to ObjectWalker in your state machine, and remove it (or install/enable the Investigative_Debugging domain from here)

Hope this helps,

Thanks so much @pemcg.

Since all I edited was a string in a field containing html, I don’t know how I called the object_walker. And removing my customization altogether should have corrected it, I would think. Since I haven’t touched the state machine, and I haven’t downloaded the Investigative_Debugging domain, it’s really a mystery to me how I’m calling the object_walker.

Thanks for your time Peter!