Disable/Suspend an Openstack Provider

Hi all,

I want to completely suspend or pause an Openstack provider to avoid MIQ to connect to this provider.

I’ve tried to disable it throught the API ( {“action”:“edit”,“resource”:{“enabled”:“false”}} ).
I now have this in the providers détails :

Capture d’écran du 2020-04-30 19-33-37 Capture d’écran du 2020-04-30 19-33-53

But, each hour, MIQ tries to check authentication status against the provider !

I’ve tried to use the Pause action but unfortunatly, as my provider as an failed authentication status, I have the following error :

“success”: false,
“message”: “Could not pause Provider - Validation failed: ManageIQ::Providers::Openstack::NetworkManager: Zone cannot be the maintenance zone when provider is active”

After disabled the provider, I’ve tried again to pause it and I have the following :

“success”: false,
“message”: “Could not pause Provider - Validation failed: ManageIQ::Providers::Openstack::CloudManager: Zone cannot be changed because the provider is paused”

Actually, I wanted to disable the provider ( and not delete it ) because of the auth failure.

For the moment, my solution is to edit the hosname to add a .disable at the end ( :slightly_frowning_face: ).

Does someone have any ideas ?

Thanks !


Hey @dotslashcmd the “paused” provider feature wasn’t fully implemented and only updating “enabled: false” doesn’t actually accomplish fully pausing the provider, the other half is that you move it to the maintenance zone.

Since the pause provider feature isn’t supported yet, recommend you create a zone with no servers in it and assign the provider to that zone.

Thanks @agrare ! I’ll look for that solution !