FYI: Ruby 2.5 on master/lasker branch will soon be unsupported

With ruby 2.5 due to reach end of life at the end of this month, we’ll be dropping support for running ruby 2.5 against manageiq’s master and the new lasker branch.

For master, we’ll be supporting ruby 2.6 and 2.7.
For lasker, we’ll be aiming for ruby 2.6 as the specific version we’ll be testing against.

There will be several pull requests to many repositories in the coming days to test against 2.6/2.7 on master and 2.6 on lasker.

Please ensure your ruby 2.6 and 2.7 environments are installed as 2.5 will soon no longer work.

1 Like

Just merged the PR to drop Ruby 2.5. Thanks @jrafanie!