Getaddrinfo: Temporary failure in name resolution


I am trying our manageiq with Mirantis openstack and am hitting an error as soon in the attached screenshot

Also note manageiq is taking the ip address of the openstack controller as the hostname and the ip address field is empty.

Is the appliance able to perform a partial lookup for the FQDN with that IP or does forward and reverse dns work?

NOTE: I am pretty new to manageiq

I don’t have DNS server running in this environment. Can I add static entries dns entries to the manageiq appliance. I am trying this our in a virtual enviroment.

I would just put an entry in etc/hosts to see if that will provide a workaround for you.

@blomquisg Didn’t we run into this at some point in the past?

How do I log into manageiq appliance and land on a bash prompt ? normal ssh does not seem to work.

Ok. I added a dns server to my setup and manageiq could now authenticate the openstack cluster using the hostname. But I am sitting hitting the same error.


Did you find a resolution for this problem? I receiving the same error in a Openstack Liberty/capablanca-2 configuration.



I have resolved the problem. The issue was that my dns did not contain an entry for one of the Openstack nodes. I found this after setting the message level for fog.log to debug. The failing connection was detailed in the log output.


Still use /etc/hosts resolv the address.

But you need login http://IPADDRESS/5000/v3/ see the real hostname. put it in your hosts file.