Global Region DB Issue

I recently tried to add some other MIQ instances as remote regions to my global MIQ instance.
I add them all and they all validated and looked good. I saved and then came out of the replication screen and back in. However, all but one was showing.

I then tried to readd but it looks like they are in the database already therefore Im unable to readd…

“Failed to save subscription to 10.x.x.x: ERROR: could not create replication slot “region_1_subscription”: ERROR: replication slot “region_1_subscription” already exists”

Any ideas on the best way to move forward?

This happened to me before. the GUI here has issue(IMO). Best way is to logout and log back in . the newly added region should show up.

To be honest i think there is more to it. As the tasks show that I am unable to add the slots to the replication DB.

However, if look through the DB i do not see any entries…

postgres=# \c vmdb_production
You are now connected to database "vmdb_production" as user "postgres".
vmdb_production=# SELECT * FROM pg_replication_slots ;
 slot_name | plugin | slot_type | datoid | database | temporary | active | active_pid | xmin | cata
log_xmin | restart_lsn | confirmed_flush_lsn
1 Like