How to update single gem in ManageIQ bundle

Hi,
I’ve got a problem like solved in this patch: https://github.com/ManageIQ/manageiq-providers-vmware/pull/690

To apply the patch the new version 1.0.9 of vmware_web_service gems should be installed. But version 1.0.8 is bundled with other MIQ gems and I can’t update it. The MIQ installation has no Internet access. So when I do ‘gem install vmware_web_service-1.0.9.gem --local --ignore-dependencies’ I get two versions (1.0.8 and 1.0.9) installed at once and MIQ continues using old one.

So please help how to update single gem in a bundle.

Thanks

Hey @vmedvedev it is probably easier to upgrade to jansa-4 which includes that fix, or better yet upgrade to the current stable release lasker-1.

Theoretically you could install the gem locally, tar cfz up the dir and extract it into the gemset directory then update the Gemfile.lock file. Unless you update that lock file manageiq will continue to use the existing gem it was built with.

1 Like

Thank you!

Yes we are planning upgrade to Lasker, but now we need fast patch.
Gemfile.lock update worked.