Importing methods from GIT, encrypted password fields

I am importing some custom ruby methods from git into the automate explorer. The issue I am hitting is that i have a password field in the instance yaml file. I am entering the password in the following format:

  • password:
    value: “v2:{xxxxxxxx==}”
    I had local versions of the instance/methods that generated the same encryption hash that I am now trying to import in via git. When I run my methods, on of which does a .decrypt on the password hash, I get the following error:

ERROR – : Error decrypting password can not decrypt v2_key encrypted string. Possible cause: Password value was encrypted with a different encryption key

Am I entering in the hash incorrectly?

The format looks OK to me. We don’t have the quotes in our YAML exports, but that should not matter in YAML…

The error message says it cannot decrypt the value. Have you tried to manually decrypt the value on the appliance?

bin/rails runner

Do you use ManageIQ tools to export/import your Automate code? If you have multiple Appliances, do all of them use the same v2_key?