Instance / Service provisioning requests stays in pending state


I’m running manageIQ from master commit#82f08de2d20f8cd577f74070062555ad3cba7cbf

Trying to launch vm’s (aws & openstack) but the requests ends up in pending state and stays there. Attempted both “launch new instance” and “order a service in catalog”. Please find the attached UI snaphot.

I couldn’t find any ERROR inside automation.log

There’re repeated ERROR’s in evm.log

I’m not sure if I’m missing any configuration?

You will need to change the max_vms value to greater then one or else the auto approval will not work. In the screen shot you have provided above you are trying to provision 3 VMs but can only do that unless you manually approve them in Services->Requests unless you change the max_vms value to <1. Please look at the screenshot I have provided below and copy this instance from your appliance into your domain so that you can edit this value to allow more than 1 VM to be auto approved.

@jdeubel thank you for helping me out.

I confirmed my max_vms value is 1. I’m having 7 requests in pending state, which I initiated one by one, and all these got auto approved.

If the request type is VM Provision, then its pending with last message as “Automation Starting” whereas its “Pending=3” for Service Provision.



@jdeubel got it fixed.

Found that “Automation Engine” server role wasn’t selected for the appliance and enabling that did the job.

Configure->Configuration->Settings->Zones->Server. Then scroll to “Server Control” section to find this option.

This solution from jayyvis worked for me also.

Is it possible for this to be made a default? On the latest nightly .ova for miq I ran across this issue.

hello @scottlinux @jayyvis @kirank @jdeubel

Although, I had the automation role enabled in the zone. It still shows me pending=3, but it worked when I changed the host to a different one in the environment tab of the catalog item.
I do not think it is only concerned with automation role, it is beyond that.
Can somebody join me for the discussion or help me finding that?

Thanking you!

Make sure you have the ‘Provider Operations’ role enabled on at least one appliance in each zone as well (even if the zone doesn’t have any providers).

Hey Peter,

From the beginning, At least one appliance in all the zones have been enabled with the provider operations.

But, VMDB appliance does not have this role enabled, although other appliances in the VMDB_zone have the role enabled. Does this show any effect?

Thanking you!