Manage Fine: Azure cloud provider not able to see instances already present in azure platform

Hi There,

I am trying to integrate azure cloud provider into manageiq fine version. but once i followed the steps and able to validate the keys successfully but after that i am not able to discover the vm’s that are already present in different resource group. Can someone please point me in a direction of what other steps i need to follow to discover the already existing instances into manageIQ.

Hi Ravikanth,

Are the VM’s you’re looking for in the region that you set the provider to? Note also that there’s currently a bug with regards to regions in India caused by a case sensitivity issue that we haven’t fixed yet, but should be fixed soon.


Hi Daniel,

Thanks a lot for the response. Yes I am selecting the correct region but
unfortunately all my vm’s are in central India region not sure if that’s
the reason I am not able to see instances and images. I am able to see all
other stuff like nsg flavour etc.

Any temp fix avlb


The planned fix is here:

If you want to apply a hotfix, that should do the trick. Be sure to backup the existing code first.


Thanks a lot Daniel will try to apply the same. Do we have any doc which
show procedure of applying this type of hot fixes. I am kind of new so just

Hi Daniel,

I was able change the code in
lib/azure/armrest/resource_group_based_service.rb as per the git lab one
and done a refresh which completed successfully…but still i am not able
to see mt instances and images in manageiq. my instances are in central


Hi Ravi,

After you applied the changes, did you restart the app? You will need to for it to pick up the changes.


Yeah i did restart the appliance and still no luck :frowning:

Not sure this has to do anything with space between central & india in
region tab and both region tab look different

Azure_new (Summary)

Region Central India
Type Azure
Management Engine GUID 7a0233d8-7799-11e7-81bd-000c299f8f3a
Region centralindia

After looking at it again, I realized that we don’t actually use the :filter option, but instead use a select block. I’ve just had a PR merged that should address it.

Hi Daniel,

I have updated the
with +44 lines in GIT and removed 3 lines. after doing that when i have
rebooted the appliance it throws error Undefined Method Describe in refresh
I have added below code to mail,

require ‘azure-armrest’

Hi Daniel,

I have just update the 3 lines and it works perfectly fine and i am able to
see all the instances that belong to resource group thanks a ton for fixing
this…Do we have similar thing for images also as i am still not able
to detect the images that belong to same resource group.

Yep, looks like private images needed an update on the azure-armrest side. So, that will be part of the 0.8.2 release, which I will incorporate into ManageIQ.

@djberg96 could this issue be the reason I have been having sporadic refresh issues - some VMs show up on my appliance and others do not? I’ve added VMs which have never refreshed.

Hey there Ravikanth_B I was just wondering how did you add the azure-armrest plugin to the manageiq version?

@jerrykbiker, If you had VM’s in an India or Canada region, then yes. Otherwise, you should not have been affected by that.

@djberg96 I kinda figured. I guess whatever refresh issue I"m having is unrelated. Thanks.

Hi all, I know this topic is old but is it possible that this same issue affects region Australia East on hammer-6? I am experiencing the same symptoms, unsure if I need to apply the hotfix as this topic is quite old. Thanks.