Manageiq Docker on Openshift


I want create test manageiq for presentation. I run deploy image manageiq/manageiq:euwe-1 on openshift origin v1.3.1.
After starting pod, i checked appliance log. And have this:

I, [2017-01-25T11:23:47.931039 #64] INFO – : MIQ(ApplianceConsole::InternalDatabaseConfiguration#initialize_postgresql) : starting
E, [2017-01-25T11:23:48.632267 #64] ERROR – : MIQ(ApplianceConsole::InternalDatabaseConfiguration#initialize_postgresql) Command failed: service exit code: 1. Error: Hint: the preferred way to do this is now "/opt/rh/rh-postgresq
l95/root/usr/bin/postgresql-setup --initdb --unit rh-postgresql95-postgresql"
runuser: cannot set groups: Operation not permitted
ERROR: The /var/lib/pgsql directory has wrong permissions.
Please make sure the directory is writable by postgres.
. Output: . At: /var/www/miq/vmdb/gems/pending/appliance_console/internal_database_configuration.rb:112:in `run_initdb’

I want run postgres under postgres. But when I write su postgre, I have this:

su: cannot set groups: Operation not permitted

At the same time this image workig good under docker on my local computer.

Who knows the reason for this behavior in openshift host?

P.S. Before I run manageiq, I enable images to run with USER in the Dockerfile

$ oc edit scc restricted
Change the runAsUser.Type strategy to RunAsAny.

Havent tried it myself, but I think the user in the manageiq image is root (not saying this is good).

Can you try it without that last setting?

I have same problem but now I can use root. Very impotant security parameter for manageiq pods: - privileged

So I continue my research in manageiq on openshift. Now I need build image from source and after that deploy it to openshift. I created docker image based on Docker file in github repository manageiq/manageiq. After that I added image streams with it to openshift and edit miq-template-monolithic.yaml template to my new image streams. And finally, I started command oc new-app --template=miq-template-monolitic. But pod didn’t start. In debug mode I find that postgres doesn’t up.
What do I miss? Which Docker file you use (for monolitic, I see docker file for multy node)?