ManageIQ on EKS using AWS load balancer - cannot login, timeout=false

I have deployed ManageIQ to AWS to managed kubernetes EKS using ManageIQ operator using these instructions: ManageIQ
I have set up load balancer after deploying MIQ. All services are running and I can access the front page, but I cannot log in. After login I get redirected to URL http://…/?timeout=false#/

How to fix this?

I have it running on a rancher k8s cluster - did not use the crd but hacked the setup from ManageIQ - Easy Install With Kubernetes

However, from my installation the apache setup is being configured to do some url re-writing. you may want to check there (see httpd-configs configmap).

If you want to manually create the k8s objects or script them, I can create a github repo of my hacked together sources. This is working on rancher k8s and is a vanilla k8s setup of manageiq.

I have tried to look the code and scripts which are available, but I don’t understand what is wrong and why I cannot login. So it would be nice to see your configs if you have working setup.

Take a look at GitHub - spicoli9000/manageiq: my manageiq stuff...
will need to apply some updates to certain yaml files because we use a local repo. also, the ingress object will need your host name etc…

Thanks, I’ll take a look!

and now it works, thanks! I think the biggest issue here was that the load balancer was plain html and the sessions were timed out immediately. These configs helped me to understand what was really wrong.

Great!
I may test deploy to AKS so please post your findings/fix if you get a chance.